Hodžův blog

27 Led

IPSEC tunnel from Check Point to Mikrotik

Check Point configuration:
IP address WAN: 1.2.3.4
IP address LAN: 192.168.1.0/24
Username: johndoe
Password: mysecret
Shared secret: 12345678

Mikrotik configuration:
/interface l2tp-client
add connect-to=1.2.3.4 disabled=no ipsec-secret=12345678 name=l2tp-checkpoint password="mysecret" use-ipsec=yes user=johndoe
/ip ipsec proposal
set [ find default=yes ] enc-algorithms=3des pfs-group=none
/ip route
add distance=1 dst-address=192.168.1.0/24 gateway=l2tp-checkpoint

22 Led

Zapnutí DNSSEC na Windows 2016

DnsCmd.exe /Config /enablednssec 1

13 Led

Getent passwd dosen’t show all users of LDAP server (Can’t receive more than 500 entries)

Quick fix:
echo "dn: cn=config
changetype: modify
replace: olcSizeLimit
olcSizeLimit: 10000" > olcSizeLimit.ldif


ldapmodify -Y EXTERNAL -H ldapi:/// -f olcSizeLimit.ldif

13 Led

SSL Library Error: 185073780 key values mismatch

When installing a certificate on Apache web server, you might receive an error SSL Library Error: 185073780 error:0B080074:x509 certificate routines:X509_check_private_key:key values mismatch during restart of Apache service.

Most often, this error appears if you are using an incorrect private key along with the certificate you received from the Certificate Authority. In order for Apache to accept certificate, it should be used with the private key generated along with the CSR code submitted for the certificate activation.

You can check whether the certificate matches the private key using the following openssl commands:

openssl x509 -in certificate.crt -noout -modulus | openssl sha1
openssl rsa -in private.key -noout -modulus | openssl sha1

12 Led

VMware VMRC fails to install on Debian or (K)Ubuntu Linux

It appears, that update-desktop-database was not installed by default.

After an apt-get install desktop-file-utils VMware Remote Console installs without error.

12 Led

Veeam Agent – reset backup jobs (re-create the Database )

Perform the following actions:

1. Run regedit.exe and locate the HKEY_LOCAL_MACHINE\SOFTWARE\Veeam\Veeam Endpoint Backup key. Create the following value under this key:
Name = Recreatedatabase 
Type = DWORD 
Value =

2. Go to Control panel > Administrative Tools and run Services. Restart the Veeam Agent for Microsoft Windows service.

A new database instance will be created (this usually happens within 5 minutes).

31 Bře

Dell PowerEdge – /opt/dell/toolit/systems/drm_files/apply bundles.sh is invalid

How to fix Dell Deployment Toolkit “apply bundles.sh is invalid”

1. ALT+F2 (new terminal console)
2. lsblk (information about disks and partitions)
3. mount /dev/sdXY /opt/dell/toolkit/systems
4. cd /opt/dell/toolkit/systems/drm_files
5. ./apply_bundles.sh

24 Bře

chown -R root:root /

Hezké sobotní dopoledne. Myšlenkama už si vidím někde venku na procházce, ale na jednom ze serverů potřebuji ještě dodělat nějaké nastavení. Utahuji šrouby a měním práva na adresáři. Do konzole ťukám „chown -R root.root /“. 600 ms ticha a pak bolestivý záblesk v hlavě. S hrůzou v očích si uvědomuji tu fatální chybu. Nechtěl jsem změnit práva na celém systému (/) ale pouze v aktuálním adresáři (./). Jedna tečka. Tečka, která Vám změní život. Vycházka se odkládá a jde se řešit problém… Zjišťuji rozsah škod, kdy „ls“ říká, že i necelá vteřina stačí k tomu aby bylo změněno téměř vše! Proč je ten Linux tak rychlý?

Přemýšlím nad možnostmi opravy. Obnovu ze zálohy zavrhuji neboť nechci přijít o několik hodin (nejen mojí) práce. Zkoumám možnosti zálohování (dirvish), rsync, cp (–attributes-only) chmod a chown (–reference). Všechna řešení jsou z části v něčem špatná – postupuji tedy dle hesla „Čím ses pokazil, tím se taky sprav“.

Hlásím se na backup server a smolím rychlý příkaz pro výpis správných atributů ze zálohy.


find /home/dirvish/mojezaloha -printf "chown -H %u:%g %p\n" > vypis.txt

Pomocí vi v souboru vypis.txt následně opravuji cestu k souborům a adresářům. Upravený fajl nahrávám na postižený server a belskurychle ho na něm „pajpnu“.

cat vypis.txt | sh -

Oprava je naštěstí rychlá. Slunce opět vyšlo…

22 Zář

Outlook 2007 – problém s jazykem po aktualizaci Windows

Microsoft opět boduje. Po aktualizaci Windows Outlook z větší části nemluví česky ale švédsky. Řešení je naštěstí jednoduché – odinstalujte KB4011086 a následně ho v ovládacích panelech – aktualizacích skryjte.

Rychlý fix:
msiexec /package {90120000-001A-040E-0000-0000000FF1CE} /uninstall {BBE4FD45-34D1-4497-8F75-77965C4E044D} /qn /quiet /norestart

psexec \\CLIENT "msiexec.exe" /package "{90120000-001A-040E-0000-0000000FF1CE} /uninstall {BBE4FD45-34D1-4497-8F75-77965C4E044D} /qn /quiet /norestart"

01 Kvě

HowTo: SSL/TLS required but absent on data channel (ProFTPD & LFTP)

echo "" >> /etc/lftp.conf
echo "set ftp:ssl-allow true" >> /etc/lftp.conf
echo "set ftp:ssl-force true" >> /etc/lftp.conf
echo "set ftp:ssl-protect-data true" >> /etc/lftp.conf
echo "set ftp:ssl-protect-list true" >> /etc/lftp.conf

Hodžův blog is is proudly powered by Wordpress and the Magellan Theme